Why is Curate reporting a problem loading my URL?

Updated 3 days ago by Benjamin Dell

Whenever a new post is added to the library, an automatic check is triggered to make sure that the URL you are trying to promote is accessible and loading properly.

The reason we do this is to ensure that any content being shared through the library is active. Essentially what we want to avoid is a situation where someone shares your post only to find that the URL within that post is returning a 404, or worse, nothing at all.

As such, these URL verification checks are critical to ensuring the overal quality of the Curate experience.

If I know my URL is loading fine, what should I do?

In isolated cases, you may find that our system reports that a URL you are adding cannot be loaded and yet when you load it yourself in a browser, it loads fine. If this is happening, please make sure that:

a) The URL doesn't take too long to load (our automated check will give up after 30 seconds or so). If your pages are taking that long to load we strongly encourage you to speak to your developer to work out why this might be happening. Long loading times not only affect our URL checker, but also degrade the overall experience for your website visitors and will often result in higher bounce rates.

b) You may have security / spam / crawler plugin installed on your site that are blocking our URL checker from accessing the content of the page. Please refer to this help guide, for steps to resolve this.


How did we do?